Welcome to the NEW Infrared Training Forum. To view the old message board, please click here.
Connection Problem - Printable Version

+- Welcome to the NEW Infrared Training Forum. To view the old message board, please click here. (http://forum.infraredtraining.com)
+-- Forum: Thermography (/forumdisplay.php?fid=3)
+--- Forum: Thermography Applications (/forumdisplay.php?fid=5)
+--- Thread: Connection Problem (/showthread.php?tid=240)

Pages: 1 2


Connection Problem - Young - 03-01-2014 08:39 AM

I'm developing a software project with the ThermoVision SDK, my camera is T640. I have installed the drivers and the ThermoVision SDK Runtime properly. But when I connected my camera to my PC, there is no response. The digital interface and communication interface is both "USB Vedio", and the Port is auto, the sever is localhost.

I tried the samples which is named "FSVB.NET" and FSWin in the SDK, but there is no difference. I don't know what's the problem.


Is there anybody know that how to connect the camera to PC correctly? Is there any documents except the SDK user's manual? Please sent to my email hustouyangxu@gmail.com and thank you!


RE: Connection Problem - acardoso - 03-01-2014 10:46 AM

Does the camera connect with Flir Tools?
António


RE: Connection Problem - Young - 03-02-2014 01:45 AM

(03-01-2014 10:46 AM)acardoso Wrote:  Does the camera connect with Flir Tools?
António


What do you mean about "Flir Tools"? I can not understand it totally… I used the samples in the SDK to connect camera and PC, the samples are "Flir Tools" or not?


RE: Connection Problem - jason.gagnon@flir.com - 03-03-2014 10:39 AM

It is possible that the camera is not connecting to the PC properly. Before going any further I would suggest restoring defaults from the camera menus:
1. Press the Menu button.
2. Select Settings.
3. From the first tab select “Restore to default settings”.

Check Device Manager, the camera should appear as a FLIR USB Video device in the Imaging Devices category.
Start the fswin.exe program from C:\Program Files\FLIR Systems\ThermoVision SDK\Binaries. Click Settings and use the following:
Camera type: T620/T640
Digital interface: USB Video
Comm interface: USB Video
Port: Auto

Click Connect, after a few seconds you should see a green icon and the word “Connected” at the bottom of the camera control. Now click the Play button and you should see a grayscale image appear in the image box. If this is successful then the camera is connecting properly.
Jason Gagnon
FLIR Systems, Inc.
jason.gagnon@flir.com
http://support.flir.com






RE: Connection Problem - Young - 03-06-2014 12:01 AM

(03-03-2014 10:39 AM)jason.gagnon@flir.com Wrote:  It is possible that the camera is not connecting to the PC properly. Before going any further I would suggest restoring defaults from the camera menus:
1. Press the Menu button.
2. Select Settings.
3. From the first tab select “Restore to default settings”.

Check Device Manager, the camera should appear as a FLIR USB Video device in the Imaging Devices category.
Start the fswin.exe program from C:\Program Files\FLIR Systems\ThermoVision SDK\Binaries. Click Settings and use the following:
Camera type: T620/T640
Digital interface: USB Video
Comm interface: USB Video
Port: Auto

Click Connect, after a few seconds you should see a green icon and the word “Connected” at the bottom of the camera control. Now click the Play button and you should see a grayscale image appear in the image box. If this is successful then the camera is connecting properly.
Jason Gagnon
FLIR Systems, Inc.
jason.gagnon@flir.com
http://support.flir.com





I have restored the camera to default settings successfully, and in the Imaging Devices category I can find the camera as a USB Video device(but not "FLIR" USB Video device). But it's still failed, and the staus is "Device not present".

P.S I can connect camera to PC successfully using the FLIR Tools.


RE: Connection Problem - jason.gagnon@flir.com - 03-06-2014 09:34 AM

What is the camera software version? This can be found on the Information tab.
What SDK version do you have? The latest is 2.6 SP2: http://support.flir.com/SwDownload/app/RssSWDownload.aspx?ID=62
Jason


RE: Connection Problem - Young - 03-11-2014 04:22 AM

(03-06-2014 09:34 AM)jason.gagnon@flir.com Wrote:  What is the camera software version? This can be found on the Information tab.
What SDK version do you have? The latest is 2.6 SP2: http://support.flir.com/SwDownload/app/RssSWDownload.aspx?ID=62
Jason


My SDK is 2.6 SP2, but I don't know my camera software version, is that very important? I will check it tomorrow.


RE: Connection Problem - Young - 03-12-2014 10:59 AM

(03-06-2014 09:34 AM)jason.gagnon@flir.com Wrote:  What is the camera software version? This can be found on the Information tab.
What SDK version do you have? The latest is 2.6 SP2: http://support.flir.com/SwDownload/app/RssSWDownload.aspx?ID=62
Jason


My camera software version is 2.34.18 and my camera type is T640_B 3.0

(03-06-2014 09:34 AM)jason.gagnon@flir.com Wrote:  What is the camera software version? This can be found on the Information tab.
What SDK version do you have? The latest is 2.6 SP2: http://support.flir.com/SwDownload/app/RssSWDownload.aspx?ID=62
Jason


Do you have any document except the SDK user's manual? If you do, can you send it to me? My email is hustouyangxu@gmail.com. Thank you very much!


RE: Connection Problem - Young - 03-13-2014 09:34 AM

The syntax of connect method is:

Status = Object.Connect(camera, port, device, interface, server)

And when I use T640, there is no server, so how should I use this method correctly? Should I let the server = 0?


RE: Connection Problem - jason.gagnon@flir.com - 03-13-2014 10:52 AM

The latest camera firmware version is 2.37C.20. The camera can be updated using the SD card, here is a link: http://support.flir.com/SwDownload/app/RssSWDownload.aspx?ID=128
For assistance with the SDK please ask a question at our Support Center website so we can assign the case to a product specialist: http://flir.custhelp.com/app/ask
Regards,
Jason